$re = '/[\b(dai|da)\b(\h{0,2}|:{1})][\d{1,2}][(\h{1}\b(anni|a|ai)\b\h{0,1}][(\d{1,2})]?/mi';
$str = 'da 5 anni
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);