using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d\..*(Latest|Updated)[\s\S]*?(?=\r?\n?\d\.)";
string input = @"3. The latest versions of the Sanctions lists are accessible on the UN Security
Council’s website at the following URL:a) List of individuals and entities issued by the UNSC ISIL (Da’esh) and Al-Qaida
Sanctions Committee:
https://www.un.org/securitycouncil/sanctions/1267/aq_sanctions_list
b) List issued by the UNSC Committee established pursuant to
resolution 1988 (2011) of individuals and entities linked to Taliban
https://www.un.org/securitycouncil/sanctions/1988/materials
4. This information is being
5. This is test";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}