const regex = /\d\..*(Latest|Updated)[\s\S]*?(?=\r?\n?\d\.)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d\\..*(Latest|Updated)[\\s\\S]*?(?=\\r?\\n?\\d\\.)', 'gmi')
const str = `3. The latest versions of the Sanctions lists are accessible on the UN Security
Council’s website at the following URL:a) List of individuals and entities issued by the UNSC ISIL (Da’esh) and Al-Qaida
Sanctions Committee:
https://www.un.org/securitycouncil/sanctions/1267/aq_sanctions_list
b) List issued by the UNSC Committee established pursuant to
resolution 1988 (2011) of individuals and entities linked to Taliban
https://www.un.org/securitycouncil/sanctions/1988/materials
4. This information is being
5. This is test`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}