import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d\\..*(Latest|Updated)[\\s\\S]*?(?=\\r?\\n?\\d\\.)";
final String string = "3. The latest versions of the Sanctions lists are accessible on the UN Security\n"
+ "Council’s website at the following URL:a) List of individuals and entities issued by the UNSC ISIL (Da’esh) and Al-Qaida\n"
+ "Sanctions Committee:\n\n"
+ "https://www.un.org/securitycouncil/sanctions/1267/aq_sanctions_list\n"
+ "b) List issued by the UNSC Committee established pursuant to\n"
+ "resolution 1988 (2011) of individuals and entities linked to Taliban\n"
+ "https://www.un.org/securitycouncil/sanctions/1988/materials\n\n"
+ "4. This information is being\n\n\n"
+ "5. This is test";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}