import re
regex = re.compile(r"<blockquote[^>]*>((?>.|\s)+?)[^>]*<cite[^>]*>((?>.|\s)+?)<\/cite><\/blockquote>")
test_str = "<blockquote><p>simply dummy text of the printing and typesetting industry. Lorem Ipsum has been the industry's standard dummy text ever since the 1500s, when an unknown printer took a galley of type and scrambled it to make a type specimen book.</p><cite>John Doe</cite></blockquote>"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")