re = /<blockquote[^>]*>((?>.|\s)+?)[^>]*<cite[^>]*>((?>.|\s)+?)<\/cite><\/blockquote>/
str = '<blockquote><p>simply dummy text of the printing and typesetting industry. Lorem Ipsum has been the industry\'s standard dummy text ever since the 1500s, when an unknown printer took a galley of type and scrambled it to make a type specimen book.</p><cite>John Doe</cite></blockquote>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end