const regex = /(?:\s*\b[a-z]+){0,}\h*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\s*\\b[a-z]+){0,}\\h*$', 'gm')
const str = `John Doe waves
Bakary N'Diaye says hello
Iván Aguilar goes well
Cisteró shot
Dan I Soylu shots
Mike van der Hoorn with a cross
M.J. Williams takes a shot
Donny van de Beek left foot
Mike van der Hoorn hello
Artak G. Grigoryan with through ball
Trent Alexander-Arnold after a break `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);