# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\s*\b[a-z]+){0,}\h*$"
test_str = ("John Doe waves \n"
"Bakary N'Diaye says hello \n"
"Iván Aguilar goes well \n"
"Cisteró shot \n"
"Dan I Soylu shots \n"
"Mike van der Hoorn with a cross \n"
"M.J. Williams takes a shot \n"
"Donny van de Beek left foot \n"
"Mike van der Hoorn hello \n"
"Artak G. Grigoryan with through ball \n"
"Trent Alexander-Arnold after a break ")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.