re = /(?:\s*\b[a-z]+){0,}\h*$/m
str = 'John Doe waves
Bakary N\'Diaye says hello
Iván Aguilar goes well
Cisteró shot
Dan I Soylu shots
Mike van der Hoorn with a cross
M.J. Williams takes a shot
Donny van de Beek left foot
Mike van der Hoorn hello
Artak G. Grigoryan with through ball
Trent Alexander-Arnold after a break '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result