using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-z]\((([a-z]+,?)*)\)";
string input = @"Tower.getType(i,b,d,name,beta).initialPrice(f);
Tower.getType().initialPrice(f);";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}