$re = '/[a-z]\((([a-z]+,?)*)\)/i';
$str = 'Tower.getType(i,b,d,name,beta).initialPrice(f);
Tower.getType().initialPrice(f);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);