re = /[a-z]\((([a-z]+,?)*)\)/i
str = 'Tower.getType(i,b,d,name,beta).initialPrice(f);
Tower.getType().initialPrice(f);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end