using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"( { ( (?: [^{}]* | (?1) )* ) } )";
string input = @"The quick brown {fox, dragon, dinosaur} jumps over the lazy {dog, cat, bear, {lion, tiger}}.";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}