package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?x)( { ( (?: [^{}]* | (?1) )* ) } )`)
var str = `The quick brown {fox, dragon, dinosaur} jumps over the lazy {dog, cat, bear, {lion, tiger}}.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}