re = /( { ( (?: [^{}]* | (?1) )* ) } )/x
str = 'The quick brown {fox, dragon, dinosaur} jumps over the lazy {dog, cat, bear, {lion, tiger}}.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end