import re
regex = re.compile(r"([^a-z0-9\)\];\-_]*\{)", flags=re.IGNORECASE)
test_str = ("a {\n"
"color:black;\n"
"background-color:blue;\n"
"}\n\n"
"{color:red}\n"
"<!-- TEST -->\n\n"
"@media screen and (max-width:620px) {\n"
"/* TEST 2 */\n"
"a.test {color:blue;}\n"
"p[class=\"test2\"] {color:green;}\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")