re = /([^a-z0-9\)\];\-_]*\{)/i
str = 'a {
color:black;
background-color:blue;
}
{color:red}
<!-- TEST -->
@media screen and (max-width:620px) {
/* TEST 2 */
a.test {color:blue;}
p[class="test2"] {color:green;}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end