#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)http:\/\/www\.opera\.com(?!.*changelogs)(\/[^\/]+)*\/(\d+)\/{0,1}"
Local $sString = "http://www.opera.com/docs/changelogs/unified/1215/" & @CRLF & _
"http://www.opera.com/docs/changelogs/anythingelse/anything/1215/" & @CRLF & _
"http://www.opera.com/security/advisory/1047" & @CRLF & _
"http://www.opera.com/security/advisory/1048/" & @CRLF & _
"http://www.opera.com/doesnt/matter/could/be/anything/1049/" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")