use strict;
my $str = 'http://www.opera.com/docs/changelogs/unified/1215/
http://www.opera.com/docs/changelogs/anythingelse/anything/1215/
http://www.opera.com/security/advisory/1047
http://www.opera.com/security/advisory/1048/
http://www.opera.com/doesnt/matter/could/be/anything/1049/
';
my $regex = qr/http:\/\/www\.opera\.com(?!.*changelogs)(\/[^\/]+)*\/(\d+)\/{0,1}/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}