$re = '/http:\/\/www\.opera\.com(?!.*changelogs)(\/[^\/]+)*\/(\d+)\/{0,1}/mi';
$str = 'http://www.opera.com/docs/changelogs/unified/1215/
http://www.opera.com/docs/changelogs/anythingelse/anything/1215/
http://www.opera.com/security/advisory/1047
http://www.opera.com/security/advisory/1048/
http://www.opera.com/doesnt/matter/could/be/anything/1049/
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);