using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!,|^)""(?!,|$)";
string substitution = @"\\""";
string input = @"""156,000"","",""i"",""parts"",""dog"","",""Monthly ""running"" totals""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}