$re = '/(?<!,|^)"(?!,|$)/';
$str = '"156,000","","i","parts","dog","","Monthly "running" totals"';
$subst = "\\\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;