import re
regex = re.compile(r"(?<!,|^)\"(?!,|$)")
test_str = "\"156,000\",\"\",\"i\",\"parts\",\"dog\",\"\",\"Monthly \"running\" totals\""
subst = "\\\\\""
result = regex.sub(subst, test_str)
if result:
print(result)