import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Armadale|Fremantle|Butler|Mandurah|Midland|Thornlie)[^\\d\\n]+2[0-9]{4}[^\\d\\n]+$";
final String string = "Armadale Joe Bloggs 22-333-222 20001 Whitfords to Butler\n"
+ "Armadale Joe Bloggs 20001 Whitfords to Butler\n"
+ "22-333-333\n"
+ "333-333-22\n"
+ "22-22-22";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}