// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(Armadale|Fremantle|Butler|Mandurah|Midland|Thornlie)[^\d\n]+2[0-9]{4}[^\d\n]+$").unwrap();
let string = "Armadale Joe Bloggs 22-333-222 20001 Whitfords to Butler
Armadale Joe Bloggs 20001 Whitfords to Butler
22-333-333
333-333-22
22-22-22";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}