re = /(Armadale|Fremantle|Butler|Mandurah|Midland|Thornlie)[^\d\n]+2[0-9]{4}[^\d\n]+$/m
str = 'Armadale Joe Bloggs 22-333-222 20001 Whitfords to Butler
Armadale Joe Bloggs 20001 Whitfords to Butler
22-333-333
333-333-22
22-22-22'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end