#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:J(?:an(?:uar)?|u[nl]i?)|Fe(?:b(?:ruar)?)?|M(?:ärz?|ai)|A(?:pr(?:il)?|ug(?:ust)?)|Sep(?:tember)?|(?:Nov|Dez)(?:ember)?|Okt(?:ober)?)"
Local $sString = "Januar Jan" & @CRLF & _
"Februar Feb " & @CRLF & _
"März Mär" & @CRLF & _
"April Apr" & @CRLF & _
"Mai" & @CRLF & _
"Jun Juni" & @CRLF & _
"Juli Jul" & @CRLF & _
"August Aug" & @CRLF & _
"Sep September" & @CRLF & _
"Okt Oktober" & @CRLF & _
"Nov November" & @CRLF & _
"Dez Dezember"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")