import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:J(?:an(?:uar)?|u[nl]i?)|Fe(?:b(?:ruar)?)?|M(?:ärz?|ai)|A(?:pr(?:il)?|ug(?:ust)?)|Sep(?:tember)?|(?:Nov|Dez)(?:ember)?|Okt(?:ober)?)";
final String string = "Januar Jan\n"
+ "Februar Feb \n"
+ "März Mär\n"
+ "April Apr\n"
+ "Mai\n"
+ "Jun Juni\n"
+ "Juli Jul\n"
+ "August Aug\n"
+ "Sep September\n"
+ "Okt Oktober\n"
+ "Nov November\n"
+ "Dez Dezember";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}