re = /(?:J(?:an(?:uar)?|u[nl]i?)|Fe(?:b(?:ruar)?)?|M(?:ärz?|ai)|A(?:pr(?:il)?|ug(?:ust)?)|Sep(?:tember)?|(?:Nov|Dez)(?:ember)?|Okt(?:ober)?)/m
str = 'Januar Jan
Februar Feb
März Mär
April Apr
Mai
Jun Juni
Juli Jul
August Aug
Sep September
Okt Oktober
Nov November
Dez Dezember'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end