package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(.*?(404|410))\/\d+$`)
var str = `http://www.agencedevoyage.com/voyage/ameriques/etats-unis/2/`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}