$re = '/^(.*?(404|410))\/\d+$/';
$str = 'http://www.agencedevoyage.com/voyage/ameriques/etats-unis/2/';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);