re = /(?<!^)"(?!$)/m
str = 'Stage 2:
field
"another "field""
""another" field"
"fie|ld"'
subst = '""'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result