package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)RL2\.[^\s<\]]*`)
var str = `-- [RL2.OPT.TEST.01]
-- [RL2.OPT.TEST.01] some more text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}