// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)RL2\.[^\s<\]]*").unwrap();
let string = "-- [RL2.OPT.TEST.01]
-- [RL2.OPT.TEST.01] some more text";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}