$re = '/RL2\.[^\s<\]]*/m';
$str = '-- [RL2.OPT.TEST.01]
-- [RL2.OPT.TEST.01] some more text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);