const regex = /^(\d{2})\b.*credits between.*\b(\d{2})$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d{2})\\b.*credits between.*\\b(\\d{2})$', '')
const str = `04 credits between subjects of block 02`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}