re = /^(\d{2})\b.*credits between.*\b(\d{2})$/
str = '04 credits between subjects of block 02'
# Print the match result
str.match(re) do |match|
puts match.to_s
end