$re = '/^(\d{2})\b.*credits between.*\b(\d{2})$/';
$str = '04 credits between subjects of block 02';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);