using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=(?!\d+\D0?2\D29)|(?=\d{2}(?:04|08|[13579][26]|[2468][048]|1[26]00|2000)\D0?2\D29))(1\d{3}|20(?:0\d|1[0-4]))[\/.]((?:0?[13578]|10|12)[\/.](?:[0-2]?\d|3[0-1])|(?:0?[469]|11)[\/.](?:[0-2]?\d|30)|0?2[\/.](?:[0-1]?\d|2[0-9]))$";
string input = @"2014/12/31
1937/4/17
1066/1/4
1066/2/28
2014/1/1
2012/02/29
1066/1/4444
1066/2/29
1065/2/29
2014/14/1
2014/02/29
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}