import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(?!\\d+\\D0?2\\D29)|(?=\\d{2}(?:04|08|[13579][26]|[2468][048]|1[26]00|2000)\\D0?2\\D29))(1\\d{3}|20(?:0\\d|1[0-4]))[\\/.]((?:0?[13578]|10|12)[\\/.](?:[0-2]?\\d|3[0-1])|(?:0?[469]|11)[\\/.](?:[0-2]?\\d|30)|0?2[\\/.](?:[0-1]?\\d|2[0-9]))$";
final String string = "2014/12/31\n"
+ "1937/4/17\n"
+ "1066/1/4\n"
+ "1066/2/28\n"
+ "2014/1/1\n"
+ "2012/02/29\n"
+ "1066/1/4444\n"
+ "1066/2/29\n"
+ "1065/2/29\n"
+ "2014/14/1\n"
+ "2014/02/29\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}