const regex = /(?:\#|\/\/)[^\n\r]*(?<![\?>])/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\#|\\\/\\\/)[^\\n\\r]*(?<![\\?>])', '')
const str = `<!--- sdsdsdsdsds --->
<!--- sdsdsdsdsds --->
<!--- sdsdsdsdsds --->
<!--- sdsdsdsdsds --->
/*asdasd asdasd asdasd
asdasd asdasd asdasds?sdsd*/
/*echo'<div class="a" id="a">Content for class "a" id "a" Goes Here</div>';*/
//sdsdsdsddsdsd
#sdsdsds?sdsd
<?php #echo'<div class="a" id="a">Content for class "a" id "a" Goes Here</div>'; ?> ?>
<?php //echo'<div class="a" id="a">Content for class "a" id "a" Goes Here</div>'; ?> ?>
<?php /*echo'<div class="a" id="a">Content for class "a" id "a" Goes Here</div>';*/ ?>
<?php /*?><?php echo'<div class="a" id="a">Content for class "a" id "a" Goes Here</div>'; ?><?php */?>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}