import re
regex = re.compile(r"(?:\#|\/\/)[^\n\r]*(?<![\?>])")
test_str = ("<!--- sdsdsdsdsds --->\n\n"
"<!--- sdsdsdsdsds --->\n\n"
"<!--- sdsdsdsdsds --->\n\n"
"<!--- sdsdsdsdsds --->\n\n"
"/*asdasd asdasd asdasd\n"
"asdasd asdasd asdasds?sdsd*/\n\n"
" /*echo'<div class=\"a\" id=\"a\">Content for class \"a\" id \"a\" Goes Here</div>';*/ \n\n"
"//sdsdsdsddsdsd\n\n"
"#sdsdsds?sdsd\n\n"
"<?php #echo'<div class=\"a\" id=\"a\">Content for class \"a\" id \"a\" Goes Here</div>'; ?> ?>\n\n"
"<?php //echo'<div class=\"a\" id=\"a\">Content for class \"a\" id \"a\" Goes Here</div>'; ?> ?>\n\n"
"<?php /*echo'<div class=\"a\" id=\"a\">Content for class \"a\" id \"a\" Goes Here</div>';*/ ?>\n\n"
"<?php /*?><?php echo'<div class=\"a\" id=\"a\">Content for class \"a\" id \"a\" Goes Here</div>'; ?><?php */?>\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")