using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":\\(\S*)\\";
string input = @"c:\foo\bar\baz.txt
C:\FOO\BAR\BAZ.TXT
C:\FoO\BaR\BaZ.TxT
C:\FoO\BaZ.TxT
C:\BaZ.TxT";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}