package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i):\\(\S*)\\`)
var str = `c:\foo\bar\baz.txt
C:\FOO\BAR\BAZ.TXT
C:\FoO\BaR\BaZ.TxT
C:\FoO\BaZ.TxT
C:\BaZ.TxT`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}