using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"DW\d{5,}";
string input = @"DW40056
DW4000057
DW4005
DW4005";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}