$re = '/DW\d{5,}/m';
$str = 'DW40056
DW4000057
DW4005
DW4005';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);