package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(https:\/\/open.spotify.com\/user\/spotify\/playlist\/|spotify:user:spotify:playlist:)([a-zA-Z0-9]+)(.*)$`)
var str = `https://open.spotify.com/user/spotify/playlist/37i9dQZF1DZ06evO2ZpGiQ?si=-6S0EBlURrao__YyIOW6bg
spotify:user:spotify:playlist:37i9dQZF1DZ06evO2ZpGiQ`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}