re = /^(https:\/\/open.spotify.com\/user\/spotify\/playlist\/|spotify:user:spotify:playlist:)([a-zA-Z0-9]+)(.*)$/m
str = 'https://open.spotify.com/user/spotify/playlist/37i9dQZF1DZ06evO2ZpGiQ?si=-6S0EBlURrao__YyIOW6bg
spotify:user:spotify:playlist:37i9dQZF1DZ06evO2ZpGiQ'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end