import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(https:\\/\\/open.spotify.com\\/user\\/spotify\\/playlist\\/|spotify:user:spotify:playlist:)([a-zA-Z0-9]+)(.*)$";
final String string = "https://open.spotify.com/user/spotify/playlist/37i9dQZF1DZ06evO2ZpGiQ?si=-6S0EBlURrao__YyIOW6bg\n"
+ "spotify:user:spotify:playlist:37i9dQZF1DZ06evO2ZpGiQ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}