const regex = /(.*-\d{8}$)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*-\\d{8}$)', '')
const str = `www.example.com/anything-here/again-here/again-hello-12543598`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}